aboutsummaryrefslogtreecommitdiffstats
path: root/tests/simple_abc9
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2019-08-17 14:37:07 +0200
committerClifford Wolf <clifford@clifford.at>2019-08-17 14:37:07 +0200
commit9e940f127691fe9e4fc3c4c92f6f0dc306aa9fb8 (patch)
treece7303bb51e80298e406a909ae7e2f105c96cc2e /tests/simple_abc9
parent41191f1ea48437423b4caf81e6af1e3024bb8c7d (diff)
downloadyosys-9e940f127691fe9e4fc3c4c92f6f0dc306aa9fb8.tar.gz
yosys-9e940f127691fe9e4fc3c4c92f6f0dc306aa9fb8.tar.bz2
yosys-9e940f127691fe9e4fc3c4c92f6f0dc306aa9fb8.zip
Speed up "make test" and related cleanups
Signed-off-by: Clifford Wolf <clifford@clifford.at>
Diffstat (limited to 'tests/simple_abc9')
-rwxr-xr-xtests/simple_abc9/run-test.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/simple_abc9/run-test.sh b/tests/simple_abc9/run-test.sh
index 4935d41ad..49ae23338 100755
--- a/tests/simple_abc9/run-test.sh
+++ b/tests/simple_abc9/run-test.sh
@@ -18,5 +18,6 @@ if ! which iverilog > /dev/null ; then
fi
cp ../simple/*.v .
+cp ../simple/*.sv .
DOLLAR='?'
-exec ${MAKE:-make} -f ../tools/autotest.mk $seed *.v EXTRA_FLAGS="-p 'hierarchy; synth -run coarse; opt -full; techmap; abc9 -lut 4 -box ../abc.box; stat; check -assert; select -assert-none t:${DOLLAR}_NOT_ t:${DOLLAR}_AND_ %%'"
+exec ${MAKE:-make} -f ../tools/autotest.mk $seed *.v EXTRA_FLAGS="-n 300 -p 'hierarchy; synth -run coarse; opt -full; techmap; abc9 -lut 4 -box ../abc.box; stat; check -assert; select -assert-none t:${DOLLAR}_NOT_ t:${DOLLAR}_AND_ %%'"