aboutsummaryrefslogtreecommitdiffstats
path: root/tests/techmap/run-test.sh
diff options
context:
space:
mode:
authorEddie Hung <eddie@fpgeh.com>2019-08-28 09:21:03 -0700
committerEddie Hung <eddie@fpgeh.com>2019-08-28 09:21:03 -0700
commitba5d81c7f1d97ca09cefb0185b33e549e166cee2 (patch)
treec70d709c9522c2b15891c40c1e265f5c2779465a /tests/techmap/run-test.sh
parent9172d4a6740145e7b3c7c34b8fb5effd23598a94 (diff)
parent13424352cc8dca5f08ad22aa42066dc7f62afea5 (diff)
downloadyosys-ba5d81c7f1d97ca09cefb0185b33e549e166cee2.tar.gz
yosys-ba5d81c7f1d97ca09cefb0185b33e549e166cee2.tar.bz2
yosys-ba5d81c7f1d97ca09cefb0185b33e549e166cee2.zip
Merge remote-tracking branch 'origin/master' into eddie/xilinx_srl
Diffstat (limited to 'tests/techmap/run-test.sh')
-rwxr-xr-xtests/techmap/run-test.sh24
1 files changed, 17 insertions, 7 deletions
diff --git a/tests/techmap/run-test.sh b/tests/techmap/run-test.sh
index e2fc11e52..96489ff15 100755
--- a/tests/techmap/run-test.sh
+++ b/tests/techmap/run-test.sh
@@ -1,10 +1,20 @@
-#!/bin/bash
+#!/usr/bin/env bash
set -e
-for x in *_runtest.sh; do
- echo "Running $x.."
- if ! bash $x &> ${x%.sh}.log; then
- tail ${x%.sh}.log
- echo ERROR
- exit 1
+{
+echo "all::"
+for x in *.ys; do
+ echo "all:: run-$x"
+ echo "run-$x:"
+ echo " @echo 'Running $x..'"
+ echo " @../../yosys -ql ${x%.ys}.log $x"
+done
+for s in *.sh; do
+ if [ "$s" != "run-test.sh" ]; then
+ echo "all:: run-$s"
+ echo "run-$s:"
+ echo " @echo 'Running $s..'"
+ echo " @bash $s > ${s%.sh}.log 2>&1"
fi
done
+} > run-test.mk
+exec ${MAKE:-make} -f run-test.mk