aboutsummaryrefslogtreecommitdiffstats
path: root/tests/verilog/run-test.sh
diff options
context:
space:
mode:
authorEddie Hung <eddie@fpgeh.com>2020-05-14 09:45:54 -0700
committerGitHub <noreply@github.com>2020-05-14 09:45:54 -0700
commit5bcde7ccc331e575682823222c97cc414bb3d808 (patch)
tree07405fdd0d0652ad75bb881ef67fa66a5e3315a3 /tests/verilog/run-test.sh
parentf02e20907e5d0f343c83ed1a762a39299105167e (diff)
parent56a5b1d2daf1b244990d81f32183034071ebd185 (diff)
downloadyosys-5bcde7ccc331e575682823222c97cc414bb3d808.tar.gz
yosys-5bcde7ccc331e575682823222c97cc414bb3d808.tar.bz2
yosys-5bcde7ccc331e575682823222c97cc414bb3d808.zip
Merge pull request #2045 from YosysHQ/eddie/fix2042
verilog: error if no direction given for task arguments, default to input in SV mode
Diffstat (limited to 'tests/verilog/run-test.sh')
-rwxr-xr-xtests/verilog/run-test.sh20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/verilog/run-test.sh b/tests/verilog/run-test.sh
new file mode 100755
index 000000000..ea56b70f0
--- /dev/null
+++ b/tests/verilog/run-test.sh
@@ -0,0 +1,20 @@
+#!/usr/bin/env bash
+set -e
+{
+echo "all::"
+for x in *.ys; do
+ echo "all:: run-$x"
+ echo "run-$x:"
+ echo " @echo 'Running $x..'"
+ echo " @../../yosys -ql ${x%.ys}.log $x"
+done
+for s in *.sh; do
+ if [ "$s" != "run-test.sh" ]; then
+ echo "all:: run-$s"
+ echo "run-$s:"
+ echo " @echo 'Running $s..'"
+ echo " @bash $s"
+ fi
+done
+} > run-test.mk
+exec ${MAKE:-make} -f run-test.mk