aboutsummaryrefslogtreecommitdiffstats
path: root/techlibs/common/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to 'techlibs/common/Makefile.inc')
-rw-r--r--techlibs/common/Makefile.inc32
1 files changed, 21 insertions, 11 deletions
diff --git a/techlibs/common/Makefile.inc b/techlibs/common/Makefile.inc
index 6d94d5c9b..7c8cc2f66 100644
--- a/techlibs/common/Makefile.inc
+++ b/techlibs/common/Makefile.inc
@@ -1,25 +1,35 @@
+OBJS += techlibs/common/synth.o
+
EXTRA_TARGETS += techlibs/common/blackbox.v
techlibs/common/blackbox.v: techlibs/common/blackbox.sed techlibs/common/simlib.v techlibs/common/simcells.v
- cat techlibs/common/simlib.v techlibs/common/simcells.v | sed -rf techlibs/common/blackbox.sed > techlibs/common/blackbox.v.new
- mv techlibs/common/blackbox.v.new techlibs/common/blackbox.v
+ $(P) cat techlibs/common/simlib.v techlibs/common/simcells.v | $(SED) -rf techlibs/common/blackbox.sed > techlibs/common/blackbox.v.new
+ $(Q) mv techlibs/common/blackbox.v.new techlibs/common/blackbox.v
-EXTRA_TARGETS += share/simlib.v share/simcells.v share/blackbox.v share/pmux2mux.v
+EXTRA_TARGETS += share/simlib.v share/simcells.v share/techmap.v share/blackbox.v share/pmux2mux.v share/adff2dff.v
share/simlib.v: techlibs/common/simlib.v
- mkdir -p share
- cp techlibs/common/simlib.v share/simlib.v
+ $(P) mkdir -p share
+ $(Q) cp techlibs/common/simlib.v share/simlib.v
share/simcells.v: techlibs/common/simcells.v
- mkdir -p share
- cp techlibs/common/simcells.v share/simcells.v
+ $(P) mkdir -p share
+ $(Q) cp techlibs/common/simcells.v share/simcells.v
+
+share/techmap.v: techlibs/common/techmap.v
+ $(P) mkdir -p share
+ $(Q) cp techlibs/common/techmap.v share/techmap.v
share/blackbox.v: techlibs/common/blackbox.v
- mkdir -p share
- cp techlibs/common/blackbox.v share/blackbox.v
+ $(P) mkdir -p share
+ $(Q) cp techlibs/common/blackbox.v share/blackbox.v
share/pmux2mux.v: techlibs/common/pmux2mux.v
- mkdir -p share
- cp techlibs/common/pmux2mux.v share/pmux2mux.v
+ $(P) mkdir -p share
+ $(Q) cp techlibs/common/pmux2mux.v share/pmux2mux.v
+
+share/adff2dff.v: techlibs/common/adff2dff.v
+ $(P) mkdir -p share
+ $(Q) cp techlibs/common/adff2dff.v share/adff2dff.v