aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests')
-rwxr-xr-xtests/simple_abc9/run-test.sh2
-rw-r--r--tests/various/pmux2shiftx.ys4
2 files changed, 3 insertions, 3 deletions
diff --git a/tests/simple_abc9/run-test.sh b/tests/simple_abc9/run-test.sh
index af003d52e..97f284378 100755
--- a/tests/simple_abc9/run-test.sh
+++ b/tests/simple_abc9/run-test.sh
@@ -19,4 +19,4 @@ fi
cp ../simple/*.v .
DOLLAR='?'
-exec ${MAKE:-make} -f ../tools/autotest.mk $seed *.v EXTRA_FLAGS="-p 'hierarchy; synth -run coarse; techmap; opt -full; abc9 -lut 4; stat; check -assert; select -assert-none t:${DOLLAR}_NOT_ t:${DOLLAR}_AND_'"
+exec ${MAKE:-make} -f ../tools/autotest.mk $seed *.v EXTRA_FLAGS="-p 'hierarchy; synth -run coarse; techmap; opt -full; abc9 -lut 4; stat; check -assert; select -assert-none t:${DOLLAR}_NOT_ t:${DOLLAR}_AND_ %%'"
diff --git a/tests/various/pmux2shiftx.ys b/tests/various/pmux2shiftx.ys
index 6bb9626eb..deb134083 100644
--- a/tests/various/pmux2shiftx.ys
+++ b/tests/various/pmux2shiftx.ys
@@ -9,8 +9,8 @@ opt
stat
# show -width
select -assert-count 1 t:$sub
-select -assert-count 2 t:$mux
-select -assert-count 2 t:$shift
+select -assert-count 1 t:$mux
+select -assert-count 1 t:$shift
select -assert-count 3 t:$shiftx
design -stash gate