aboutsummaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-ks8695/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/arm/mach-ks8695/Makefile')
-rw-r--r--arch/arm/mach-ks8695/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/arch/arm/mach-ks8695/Makefile b/arch/arm/mach-ks8695/Makefile
new file mode 100644
index 00000000..7e3e8160
--- /dev/null
+++ b/arch/arm/mach-ks8695/Makefile
@@ -0,0 +1,20 @@
+# arch/arm/mach-ks8695/Makefile
+#
+# Makefile for KS8695 architecture support
+#
+
+obj-y := cpu.o irq.o time.o gpio.o devices.o
+obj-m :=
+obj-n :=
+obj- :=
+
+# PCI support is optional
+obj-$(CONFIG_PCI) += pci.o
+
+# LEDs
+obj-$(CONFIG_LEDS) += leds.o
+
+# Board-specific support
+obj-$(CONFIG_MACH_KS8695) += board-micrel.o
+obj-$(CONFIG_MACH_DSM320) += board-dsm320.o
+obj-$(CONFIG_MACH_ACS5K) += board-acs5k.o