aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/xen/xenbus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/xen/xenbus/Makefile')
-rw-r--r--drivers/xen/xenbus/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/drivers/xen/xenbus/Makefile b/drivers/xen/xenbus/Makefile
new file mode 100644
index 00000000..8dca6853
--- /dev/null
+++ b/drivers/xen/xenbus/Makefile
@@ -0,0 +1,12 @@
+obj-y += xenbus.o
+
+xenbus-objs =
+xenbus-objs += xenbus_client.o
+xenbus-objs += xenbus_comms.o
+xenbus-objs += xenbus_xs.o
+xenbus-objs += xenbus_probe.o
+
+xenbus-be-objs-$(CONFIG_XEN_BACKEND) += xenbus_probe_backend.o
+xenbus-objs += $(xenbus-be-objs-y)
+
+obj-$(CONFIG_XEN_XENBUS_FRONTEND) += xenbus_probe_frontend.o