diff options
author | Henrik Rydberg <rydberg@euromail.se> | 2008-11-06 23:01:41 +0100 |
---|---|---|
committer | Henrik Rydberg <rydberg@euromail.se> | 2008-11-06 23:01:41 +0100 |
commit | d44b4794c679141a08fd802475bb542ecf5b7c51 (patch) | |
tree | 74251970cfbcc58d0252366be6e5e668149b8a48 /Makefile | |
parent | 63de72d8d810e3692c96c7385b497bb4d68ef54a (diff) | |
download | xorg-input-kobomultitouch-d44b4794c679141a08fd802475bb542ecf5b7c51.tar.gz xorg-input-kobomultitouch-d44b4794c679141a08fd802475bb542ecf5b7c51.tar.bz2 xorg-input-kobomultitouch-d44b4794c679141a08fd802475bb542ecf5b7c51.zip |
ok, fast (but not fastest) matcher in place, no check output...
Signed-off-by: Henrik Rydberg <rydberg@euromail.se>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 15 |
1 files changed, 10 insertions, 5 deletions
@@ -1,6 +1,8 @@ LIBRARY = multitouch.so FDIS = 11-multitouch.fdi -MODULES = src +MODULES = match src + +o_match = match o_src = capabilities \ iobuffer \ @@ -31,13 +33,11 @@ OPTS = -O3 .PHONY: all clean .PRECIOUS: obj/%.o -all: $(OBJS) $(TLIB) $(TOBJ) - -test: $(TBIN) +all: $(OBJS) $(TLIB) $(TOBJ) $(TBIN) bin/%: obj/%.o @mkdir -p $(@D) - gcc $< $(OBJS) $(LIBS) -o $@ + gcc $< -o $@ $(TLIB): $(OBJS) @rm -f $(TLIB) @@ -62,3 +62,8 @@ install: $(TLIB) $(TFDI) install -d "$(DESTDIR)/$(DFDI)" install -m 755 $(TLIB) "$(DESTDIR)/$(DLIB)" install -m 644 $(TFDI) "$(DESTDIR)/$(DFDI)" + +test: + gcc $< $(OBJS) -o LINKTEST + +obj/match/test.o: match/match.c |