summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index f258e30..5f21816 100644
--- a/Makefile
+++ b/Makefile
@@ -132,13 +132,6 @@ ${PROG}:${OBJS}
$(CC) $(CPPFLAGS) $(ASFLAGS) -c -o $@ $<
-flash: ${PROG}.hex
- ${OOCD} -f ${OOCD_CFG} \
- -c "init" -c "reset init" \
- -c "flash write_image erase $<" \
- -c "reset" \
- -c "shutdown"
-
ds:
$(OOCD) -f $(OOCD_CFG)
@@ -156,6 +149,23 @@ reset:
%.zip: %.hex
${NRFUTIL} dfu genpkg --dev-revision ${DEV_REVISION} --dev-type ${DEV_TYPE} --application-version ${APP_VERSION} --sd-req ${SD_REQ} --application $< $@
+flash: ${PROG}.hex
+ ${OOCD} -f ${OOCD_CFG} \
+ -c "init" -c "reset init" \
+ -c "flash write_image erase $<" \
+ -c "reset" \
+ -c "shutdown"
+
+
+
+flash_softdevice: ${SOFTDEVICE}
+ ${OOCD} -f ${OOCD_CFG} \
+ -c "init" -c "reset init" \
+ -c "nrf51 mass_erase" \
+ -c "flash write_image erase $<" \
+ -c "reset" \
+ -c "shutdown"
+
dfu: ${PROG}.zip
nrfdfu -b ${BDADDR} -p ${PROG}.zip