aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-03-29 20:26:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-03-29 20:26:45 +0000
commit079a6e99c982cc0c0624b0d7e07a19c9692a7cbe (patch)
tree5bc9ba0c629f341ed7aa6ccf4f25397e9b1490d3
parent6562bf096516b1d5e9fa2abcb48329271f563db6 (diff)
downloadmaster-187ad058-079a6e99c982cc0c0624b0d7e07a19c9692a7cbe.tar.gz
master-187ad058-079a6e99c982cc0c0624b0d7e07a19c9692a7cbe.tar.bz2
master-187ad058-079a6e99c982cc0c0624b0d7e07a19c9692a7cbe.zip
[package] busybox: avoid infinite loop in lsmod (#4834)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15071 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/busybox/Makefile2
-rw-r--r--package/busybox/patches/810-lsmod-infinite-loop.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 3f27ec66c4..8eede35993 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.11.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/patches/810-lsmod-infinite-loop.patch b/package/busybox/patches/810-lsmod-infinite-loop.patch
new file mode 100644
index 0000000000..8bc8cd0a76
--- /dev/null
+++ b/package/busybox/patches/810-lsmod-infinite-loop.patch
@@ -0,0 +1,11 @@
+--- a/modutils/lsmod.c
++++ b/modutils/lsmod.c
+@@ -107,7 +107,7 @@
+ continue;
+ } else if (errno != ENOSPC)
+ bb_perror_msg_and_die("module %s: QM_REFS", mn);
+- deps = xrealloc(deps, count);
++ deps = xrealloc(deps, depsize = count);
+ }
+ printf("%-20s%8lu%4ld", mn, info.size, info.usecount);
+ if (info.flags & NEW_MOD_DELETED)