aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-11-30 09:51:48 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-11-30 09:51:48 +0000
commit1069e426d598fe6e079471d0412ccdd6a93d29d6 (patch)
tree3e25a637e4f39195f51a93d9cff14840f47b1a4e
parent03c303d3e9efa88bf2dbf8d466fa64051ad8f8e4 (diff)
downloadmaster-187ad058-1069e426d598fe6e079471d0412ccdd6a93d29d6.tar.gz
master-187ad058-1069e426d598fe6e079471d0412ccdd6a93d29d6.tar.bz2
master-187ad058-1069e426d598fe6e079471d0412ccdd6a93d29d6.zip
[tools]: add gengetopt
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43437 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--tools/Makefile2
-rw-r--r--tools/gengetopt/Makefile28
2 files changed, 29 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index e387f44e6d..27d0dc1c79 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -28,7 +28,7 @@ tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons bc
-tools-y += findutils
+tools-y += findutils gengetopt
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
tools-$(CONFIG_powerpc) += upx
tools-$(CONFIG_TARGET_x86) += qemu
diff --git a/tools/gengetopt/Makefile b/tools/gengetopt/Makefile
new file mode 100644
index 0000000000..a66fbe6605
--- /dev/null
+++ b/tools/gengetopt/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licengengetopt under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gengetopt
+PKG_VERSION:=2.22.6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=29749a48dda69277ab969c510597a14e
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/gengetopt $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/gengetopt
+endef
+
+$(eval $(call HostBuild))