aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Dickinson <daniel@cshore.neomailbox.net>2010-12-10 18:59:58 +0000
committerDaniel Dickinson <daniel@cshore.neomailbox.net>2010-12-10 18:59:58 +0000
commit16c44de3e98304a07ab427be772bd4d614634c0c (patch)
tree6b22ba8bc00c6fe254dc1f50b976a34587def713
parentb0b20ac0a3968489c1c5117f91161447f09d2e3a (diff)
downloadmaster-187ad058-16c44de3e98304a07ab427be772bd4d614634c0c.tar.gz
master-187ad058-16c44de3e98304a07ab427be772bd4d614634c0c.tar.bz2
master-187ad058-16c44de3e98304a07ab427be772bd4d614634c0c.zip
[brcm63xx] Fixed Comtrend CT536_CT5621 board settings. These boards are based on the 96348GW-11 reference design but have different GPIOs therefore we use the board fixups now availabed (thanks the patches by Jonas Gorski) to create a separate board entry for these boards and leave the reference design with reference GPIOs. Also these boards only have enet1 (no enet0) so we set that in the board definition, and use a defconfig for a single interface network.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24442 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network14
-rwxr-xr-xtarget/linux/brcm63xx/base-files/lib/brcm63xx.sh5
-rw-r--r--target/linux/brcm63xx/image/Makefile4
-rw-r--r--target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch60
4 files changed, 82 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network b/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network
new file mode 100644
index 0000000000..a35fd2ef9a
--- /dev/null
+++ b/target/linux/brcm63xx/base-files/etc/defconfig/CT536_CT5621/network
@@ -0,0 +1,14 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
+
+config interface lan
+ option ifname eth0
+ option type bridge
+ option proto static
+ option ipaddr 192.168.1.1
+ option netmask 255.255.255.0
diff --git a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
index e2c563460a..71c188022c 100755
--- a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
+++ b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
@@ -34,6 +34,11 @@ brcm63xx_detect() {
brcm63xx_has_reset_button="true"
ifname=eth1
;;
+ "bcm63xx/CT536_CT5621 "*)
+ status_led="power"
+ brcm63xx_has_reset_button="true"
+ ifname=eth0
+ ;;
"bcm63xx/96358GW "* | "bcm63xx/SPW500V "*)
status_led="power:green"
brcm63xx_has_reset_button="true"
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 25c9b36a49..b34c7eb5dc 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -128,6 +128,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96348GW,6348,96348GW-bc221,,--layoutver 5)
$(call Image/Build/CFE,$(1),6338GW,6338,6338GW-generic,,)
$(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
+ $(call Image/Build/CFE,$(1),96348GW-11,6348,96348GW-11-gen)
+ $(call Image/Build/CFE,$(1),96348GW-10,6348,96348GW-10-gen)
# BT Voyager V210_BTR
$(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
@@ -152,7 +154,7 @@ define Image/Build
# Neufbox4
$(call Image/Build/CFE,$(1),96358VW,6358,NEUFBOX4,OpenWRT-$(REVISION))
# Comtrend 536, 5621
- $(call Image/Build/CFE,$(1),96348GW-11,6348,CT536_CT5621)
+ $(call Image/Build/CFEFIXUP,$(1),96348GW-11,6348,CT536_CT5621)
# Davolink DV201AMR
$(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
# USR 9108
diff --git a/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch b/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch
new file mode 100644
index 0000000000..e1b6342655
--- /dev/null
+++ b/target/linux/brcm63xx/patches-2.6.35/440-new_96348gw-11_leds.patch
@@ -0,0 +1,60 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -364,6 +364,49 @@ static struct board_info __initdata boar
+ },
+ };
+
++static struct board_info __initdata board_ct536_ct5621 = {
++ .name = "CT536_CT5621",
++ .expected_cpu_id = 0x6348,
++
++ .has_uart0 = 1,
++ .has_enet0 = 0,
++ .has_enet1 = 1,
++ .has_pci = 1,
++
++ .enet1 = {
++ .force_speed_100 = 1,
++ .force_duplex_full = 1,
++ },
++
++ .has_ohci0 = 1,
++ .has_pccard = 1,
++ .has_ehci0 = 1,
++
++ .leds = {
++ {
++ .name = "adsl-fail",
++ .gpio = 2,
++ .active_low = 1,
++ },
++ {
++ .name = "power",
++ .gpio = 0,
++ .active_low = 1,
++ .default_trigger = "default-on",
++ },
++ },
++ .buttons = {
++ {
++ .desc = "reset",
++ .gpio = 33,
++ .active_low = 1,
++ .type = EV_KEY,
++ .code = KEY_RESTART,
++ .threshold = 3,
++ },
++ },
++};
++
+ static struct board_info __initdata board_96348gw = {
+ .name = "96348GW",
+ .expected_cpu_id = 0x6348,
+@@ -1642,6 +1685,7 @@ static const struct board_info __initdat
+ &board_rta1025w_16,
+ &board_96348_D4PW,
+ &board_spw500v,
++ &board_ct536_ct5621,
+ #endif
+
+ #ifdef CONFIG_BCM63XX_CPU_6358