aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-25 07:08:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-25 07:08:35 +0000
commit21e832921cd728a2e039b1e4c3948a78a54f8938 (patch)
treeedd97b2839a59fdaabe2d8f347a869fc5b88a79c
parentf0f5892884903cf45b2fe3c63a98fb75d50674ac (diff)
downloadmaster-187ad058-21e832921cd728a2e039b1e4c3948a78a54f8938.tar.gz
master-187ad058-21e832921cd728a2e039b1e4c3948a78a54f8938.tar.bz2
master-187ad058-21e832921cd728a2e039b1e4c3948a78a54f8938.zip
hotplug2: add a missing cflag, allow hotplug events that are not 'add'
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7721 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/hotplug2/Makefile2
-rw-r--r--package/hotplug2/patches/120-action_types.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index bf7c8c6b09..c696f09f5b 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -29,7 +29,7 @@ define Package/hotplug2/description
Hotplug2 is a trivial replacement of some of the UDev functionality
in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
endef
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
define Package/hotplug2/install
$(INSTALL_DIR) $(1)/etc
diff --git a/package/hotplug2/patches/120-action_types.patch b/package/hotplug2/patches/120-action_types.patch
new file mode 100644
index 0000000000..c81b241b7a
--- /dev/null
+++ b/package/hotplug2/patches/120-action_types.patch
@@ -0,0 +1,13 @@
+Index: hotplug2-0.9/hotplug2.c
+===================================================================
+--- hotplug2-0.9.orig/hotplug2.c 2007-06-25 09:07:07.038012616 +0200
++++ hotplug2-0.9/hotplug2.c 2007-06-25 09:07:19.420130248 +0200
+@@ -555,7 +555,7 @@
+ if (cur_seqnum > highest_seqnum)
+ highest_seqnum = cur_seqnum;
+
+- if (tmpevent->action == ACTION_ADD && (!dumb || modalias != NULL)) {
++ if (!dumb || modalias != NULL) {
+ /*
+ * We have more children than we want. Wait until SIGCHLD handler reduces
+ * their numbers.