aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-01-26 11:33:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-01-26 11:33:46 +0000
commit3ec2817f2359d606ddfea7deab183dd6a349abf6 (patch)
tree2746fa74b2d8240a4147a25383d9d0104b309215
parent19622693b30b2deeab587aa001d749222b063121 (diff)
downloadmaster-187ad058-3ec2817f2359d606ddfea7deab183dd6a349abf6.tar.gz
master-187ad058-3ec2817f2359d606ddfea7deab183dd6a349abf6.tar.bz2
master-187ad058-3ec2817f2359d606ddfea7deab183dd6a349abf6.zip
x86/soekris: Add defconfig for soekris net4801 and net4826
Add default config file for net4801 and 4826 and initial script to copy config file like it is done for other platforms. Patch from: kentarou matsuyama <matsuyama@thinktube.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25103 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/x86/base-files.mk4
-rw-r--r--target/linux/x86/base-files/etc/defconfig/net4801/network16
-rw-r--r--target/linux/x86/base-files/etc/defconfig/net4826/network12
-rwxr-xr-xtarget/linux/x86/base-files/etc/init.d/defconfig20
4 files changed, 52 insertions, 0 deletions
diff --git a/target/linux/x86/base-files.mk b/target/linux/x86/base-files.mk
new file mode 100644
index 0000000000..29cbfda977
--- /dev/null
+++ b/target/linux/x86/base-files.mk
@@ -0,0 +1,4 @@
+define Package/base-files/install-target
+ rm -f $(1)/etc/config/network
+endef
+
diff --git a/target/linux/x86/base-files/etc/defconfig/net4801/network b/target/linux/x86/base-files/etc/defconfig/net4801/network
new file mode 100644
index 0000000000..ff7b42d875
--- /dev/null
+++ b/target/linux/x86/base-files/etc/defconfig/net4801/network
@@ -0,0 +1,16 @@
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
+
+config interface lan
+ option ifname eth1
+ option type bridge
+ option proto static
+ option ipaddr 192.168.1.1
+ option netmask 255.255.255.0
+
+config interface wan
+ option ifname eth0
+ option proto dhcp
diff --git a/target/linux/x86/base-files/etc/defconfig/net4826/network b/target/linux/x86/base-files/etc/defconfig/net4826/network
new file mode 100644
index 0000000000..7c9fb63637
--- /dev/null
+++ b/target/linux/x86/base-files/etc/defconfig/net4826/network
@@ -0,0 +1,12 @@
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
+
+config interface lan
+ option ifname eth0
+ option type bridge
+ option proto static
+ option ipaddr 192.168.1.1
+ option netmask 255.255.255.0
diff --git a/target/linux/x86/base-files/etc/init.d/defconfig b/target/linux/x86/base-files/etc/init.d/defconfig
new file mode 100755
index 0000000000..4b4f28f20d
--- /dev/null
+++ b/target/linux/x86/base-files/etc/init.d/defconfig
@@ -0,0 +1,20 @@
+#!/bin/sh /etc/rc.common
+#
+# Copyright (C) 2010 Thinktube Inc.
+#
+
+START=05
+
+start() {
+ . /lib/soekris.sh
+
+ local board=$(net48xx_board_name)
+
+ [ ! -d /etc/defconfig/$board ] && board="net4826"
+
+ for f in $( ls /etc/defconfig/$board ); do
+ if [ ! -e /etc/config/$f ]; then
+ cp /etc/defconfig/$board/$f /etc/config/
+ fi
+ done
+}