aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-03-07 10:47:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-03-07 10:47:23 +0000
commit5f2c61171077198aa1870744de34f111967658f0 (patch)
tree909a42ac7d4d4df87118a6d152432f5123b4a4e0
parent753909115e7feb1630cd19bac1e3becadecd9c70 (diff)
downloadmaster-187ad058-5f2c61171077198aa1870744de34f111967658f0.tar.gz
master-187ad058-5f2c61171077198aa1870744de34f111967658f0.tar.bz2
master-187ad058-5f2c61171077198aa1870744de34f111967658f0.zip
Add PCnet32 ethernet support (#3195)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10558 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/network.mk16
-rw-r--r--target/linux/x86/config-2.6.232
-rw-r--r--target/linux/x86/mediacenter/config-2.6.232
3 files changed, 20 insertions, 0 deletions
diff --git a/package/kernel/modules/network.mk b/package/kernel/modules/network.mk
index 03fb8a3600..f15517b814 100644
--- a/package/kernel/modules/network.mk
+++ b/package/kernel/modules/network.mk
@@ -716,6 +716,22 @@ endef
$(eval $(call KernelPackage,3c59x))
+define KernelPackage/pcnet32
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=AMD PCnet32 PCI support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_PCNET32
+ FILES:=$(LINUX_DIR)/drivers/net/pcnet32.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,pcnet32)
+endef
+
+define KernelPackage/pcnet32/description
+ Kernel modules for AMD PCnet32 Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,pcnet32))
+
+
define KernelPackage/tg3
TITLE:=Broadcom Tigon3 Gigabit Ethernet
FILES:=$(LINUX_DIR)/drivers/net/tg3.$(LINUX_KMOD_SUFFIX)
diff --git a/target/linux/x86/config-2.6.23 b/target/linux/x86/config-2.6.23
index c12a2f95cf..9b76778d03 100644
--- a/target/linux/x86/config-2.6.23
+++ b/target/linux/x86/config-2.6.23
@@ -273,6 +273,8 @@ CONFIG_PCMCIA=m
CONFIG_PCMCIA_IOCTL=y
CONFIG_PCMCIA_LOAD_CIS=y
CONFIG_PCMCIA_PROBE=y
+CONFIG_PCNET32=m
+CONFIG_PCNET32_NAPI=y
# CONFIG_PCWATCHDOG is not set
CONFIG_PHYSICAL_ALIGN=0x100000
CONFIG_PHYSICAL_START=0x100000
diff --git a/target/linux/x86/mediacenter/config-2.6.23 b/target/linux/x86/mediacenter/config-2.6.23
index a5ce3dc8d3..8845ba1b5c 100644
--- a/target/linux/x86/mediacenter/config-2.6.23
+++ b/target/linux/x86/mediacenter/config-2.6.23
@@ -290,6 +290,8 @@ CONFIG_PCMCIA=m
CONFIG_PCMCIA_IOCTL=y
CONFIG_PCMCIA_LOAD_CIS=y
CONFIG_PCMCIA_PROBE=y
+CONFIG_PCNET32=m
+CONFIG_PCNET32_NAPI=y
# CONFIG_PCWATCHDOG is not set
CONFIG_PHYSICAL_ALIGN=0x100000
CONFIG_PHYSICAL_START=0x100000