aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-02 18:12:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-02 18:12:29 +0000
commit935884df5dfe6bc939007783bd9c9338afe75577 (patch)
tree058c168b19429536a6c39b2142b712da13a47736
parentd23d9cc64dd83bf22efb1dba52844ceb41ccc18c (diff)
downloadmaster-187ad058-935884df5dfe6bc939007783bd9c9338afe75577.tar.gz
master-187ad058-935884df5dfe6bc939007783bd9c9338afe75577.tar.bz2
master-187ad058-935884df5dfe6bc939007783bd9c9338afe75577.zip
include/kernel.mk - better search for ARCH
If "findstring" is used without leading and trailing spaces unexpected matches may happen. For example consider ARC=arc then "findstring $(ARCH)" will report a false match with "aarch64". But "findstring $ARCH " (note trailing space) will correctly skip matches for both "aarch64" and "aarch64_be". This patch is built-tested against NetGear WNDR3800. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47359 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 7a0a170c35..6a613fe1fd 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -62,15 +62,15 @@ endif
ifneq (,$(findstring uml,$(BOARD)))
LINUX_KARCH=um
-else ifneq (,$(findstring $(ARCH), aarch64 aarch64_be))
+else ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be ))
LINUX_KARCH := arm64
-else ifneq (,$(findstring $(ARCH), armeb))
+else ifneq (,$(findstring $(ARCH) , armeb ))
LINUX_KARCH := arm
-else ifneq (,$(findstring $(ARCH), mipsel mips64 mips64el))
+else ifneq (,$(findstring $(ARCH) , mipsel mips64 mips64el ))
LINUX_KARCH := mips
-else ifneq (,$(findstring $(ARCH), sh2 sh3 sh4))
+else ifneq (,$(findstring $(ARCH) , sh2 sh3 sh4 ))
LINUX_KARCH := sh
-else ifneq (,$(findstring $(ARCH), i386 x86_64))
+else ifneq (,$(findstring $(ARCH) , i386 x86_64 ))
LINUX_KARCH := x86
else
LINUX_KARCH := $(ARCH)