aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2010-09-06 16:34:45 +0000
committerJohn Crispin <blogic@openwrt.org>2010-09-06 16:34:45 +0000
commit989d1dc93cec9375ded092ebd77985f8a2c8beec (patch)
tree4f134bd97a1d639e4c206547a8e8392ffb6edc88
parent38f55875a45f31167b76d85b52693bf2d4dff2d1 (diff)
downloadmaster-187ad058-989d1dc93cec9375ded092ebd77985f8a2c8beec.tar.gz
master-187ad058-989d1dc93cec9375ded092ebd77985f8a2c8beec.tar.bz2
master-187ad058-989d1dc93cec9375ded092ebd77985f8a2c8beec.zip
[ifxmips]
extracted firmware files were generated with an incorrect umask git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22957 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/ifx-vmmc/Makefile4
-rwxr-xr-xtarget/linux/ifxmips/extract.sh4
2 files changed, 4 insertions, 4 deletions
diff --git a/package/ifx-vmmc/Makefile b/package/ifx-vmmc/Makefile
index e691cd151a..1cce8555e4 100644
--- a/package/ifx-vmmc/Makefile
+++ b/package/ifx-vmmc/Makefile
@@ -104,9 +104,9 @@ endif
ifeq ($(CONFIG_VOICE_CPE_VMMC_WITH_DEVICE_DANUBE_extract),y)
define Download/decode
- FILE:=ifxmips_fw_decode.tar.bz2
+ FILE:=ifxmips_fw_decodev2.tar.bz2
URL:=http://downloads.openwrt.org/sources/
- MD5SUM:=1197ff6cace6a7c86492a468f5fbfe07
+ MD5SUM:=9f4ebfae5cb9d9e8fca46057a653ae27
endef
$(eval $(call Download,decode))
endif
diff --git a/target/linux/ifxmips/extract.sh b/target/linux/ifxmips/extract.sh
index 7b1c1da0b1..52dfbd56ea 100755
--- a/target/linux/ifxmips/extract.sh
+++ b/target/linux/ifxmips/extract.sh
@@ -11,9 +11,9 @@ echo "Please only do so if it is legal in your country"
exit 1
}
-[ -f ${DIR}/ifxmips_fw_decode.tar.bz2 -a ! -f ${DIR}voip_coef.bin ] && {
+[ -f ${DIR}/ifxmips_fw_decodev2.tar.bz2 -a ! -f ${DIR}voip_coef.bin ] && {
[ ! -f ${DIR}decode_ifx_fw ] && {
- tar xjf ${DIR}ifxmips_fw_decode.tar.bz2 ifxmips_fw_decode/decode.c -O > ${DIR}decode.c
+ tar xjf ${DIR}ifxmips_fw_decodev2.tar.bz2 ifxmips_fw_decode/decode.c -O > ${DIR}decode.c
gcc -o ${DIR}decode_ifx_fw ${DIR}decode.c
}
[ ! -f ${DIR}voip_coef.lzma ] && {