aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-02-11 08:37:57 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-02-11 08:37:57 +0000
commit98d6f0382ba5612bd5a70d92ae9674f150c16d8e (patch)
treef78a58d4803f1fe16e7da30caae7b1b9a8a8f711
parent3b4e45c0219deffd244c95116d806f7cf10af2d7 (diff)
downloadmaster-187ad058-98d6f0382ba5612bd5a70d92ae9674f150c16d8e.tar.gz
master-187ad058-98d6f0382ba5612bd5a70d92ae9674f150c16d8e.tar.bz2
master-187ad058-98d6f0382ba5612bd5a70d92ae9674f150c16d8e.zip
with no users left, remove support for 2.6.21
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19578 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in1
-rw-r--r--include/image.mk2
-rw-r--r--include/kernel-version.mk3
-rw-r--r--package/mac80211/Makefile2
-rw-r--r--tools/Makefile2
5 files changed, 3 insertions, 7 deletions
diff --git a/Config.in b/Config.in
index c798510f0c..30d7eca4a4 100644
--- a/Config.in
+++ b/Config.in
@@ -23,7 +23,6 @@ menu "Target Images"
choice
prompt "ramdisk compression"
depends TARGET_ROOTFS_INITRAMFS
- depends !LINUX_2_6_21
depends !LINUX_2_6_25
default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
default TARGET_INITRAMFS_COMPRESSION_NONE
diff --git a/include/image.mk b/include/image.mk
index 990ce8e400..e133f7212c 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -23,7 +23,7 @@ JFFS2OPTS := --pad --big-endian --squash
SQUASHFS_OPTS := -be
endif
-ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25),)
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
USE_SQUASHFS3 := y
endif
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index c2faae0d04..b2810ce75f 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,9 +8,6 @@ LINUX_RELEASE?=1
ifeq ($(LINUX_VERSION),2.4.37.5)
LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
endif
-ifeq ($(LINUX_VERSION),2.6.21.7)
- LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
-endif
ifeq ($(LINUX_VERSION),2.6.25.20)
LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
endif
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index f8d8d390f0..a9c8687637 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -40,7 +40,7 @@ endef
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack
- DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +wireless-tools +iw @!LINUX_2_6_21 @!LINUX_2_6_25
+ DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +wireless-tools +iw @!LINUX_2_6_25
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.$(LINUX_KMOD_SUFFIX) \
$(PKG_BUILD_DIR)/compat/compat_firmware_class.$(LINUX_KMOD_SUFFIX) \
diff --git a/tools/Makefile b/tools/Makefile
index 3d19892100..8fc2da3d96 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -17,7 +17,7 @@ tools-y += m4 autoconf automake bison pkg-config sed mklibs
tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2
tools-$(CONFIG_TARGET_orion) += wrt350nv2-builder upslug2
-ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25),)
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
tools-y += squashfs lzma-old
else
ifneq ($(CONFIG_TARGET_ar71xx),)