aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-24 17:15:03 +0000
commita03765d9c134d069c0c661e5fea57447a34502ac (patch)
treead6234796fabe5ab9776f28e3450fc79bf6e285d
parent9cf7b253957c0602e451496e45815b6e82c60dbb (diff)
downloadmaster-187ad058-a03765d9c134d069c0c661e5fea57447a34502ac.tar.gz
master-187ad058-a03765d9c134d069c0c661e5fea57447a34502ac.tar.bz2
master-187ad058-a03765d9c134d069c0c661e5fea57447a34502ac.zip
ar71xx: image: generate sysupgrade images for the Compex boards
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39391 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 5fe8ae4cbe..9cd9c26c36 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -457,11 +457,13 @@ define Image/Build/MyLoader
$(eval fwimage=$(KDIR_TMP)/$(2)-$(5)-firmware.bin)
$(call CatFiles,$(KDIR_TMP)/vmlinux-$(2).bin.lzma,65536,$(KDIR)/root.$(1),$(fwsize),$(fwimage))
if [ -e "$(fwimage)" ]; then \
- cp $(fwimage) $(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) -v \
-p0x00030000:0:al:0x80060000:firmware:$(fwimage) \
$(call imgname,$(1),$(2))-$(5)-factory.img; \
- true; \
+ echo -n "" > $(KDIR_TMP)/empty.bin; \
+ sh $(TOPDIR)/scripts/combined-image.sh \
+ $(fwimage) $(KDIR_TMP)/empty.bin \
+ $(call imgname,$(1),$(2))-$(5)-sysupgrade.bin; \
fi
endef