aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-11-08 07:31:25 +0000
commita4e62a74a7b798d4b20383e0529a252757d0c909 (patch)
tree04e3f1bf2d058c9d9cd9e08f33f325e0b3e8b9b4
parent58aa0fff4a5b2163798b264d8778f25bd66c2ac3 (diff)
downloadmaster-187ad058-a4e62a74a7b798d4b20383e0529a252757d0c909.tar.gz
master-187ad058-a4e62a74a7b798d4b20383e0529a252757d0c909.tar.bz2
master-187ad058-a4e62a74a7b798d4b20383e0529a252757d0c909.zip
[buildroot] make targets provide their KERNELNAME
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23919 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-defaults.mk9
-rw-r--r--target/linux/avr32/Makefile2
-rw-r--r--target/linux/rdc/Makefile2
-rw-r--r--target/linux/x86/Makefile2
4 files changed, 6 insertions, 9 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 5312ad4981..312664ab7a 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -6,15 +6,6 @@
#
KERNELNAME=
-ifneq (,$(findstring x86,$(BOARD)))
- KERNELNAME="bzImage"
-endif
-ifneq (,$(findstring rdc,$(BOARD)))
- KERNELNAME="bzImage"
-endif
-ifneq (,$(findstring avr32,$(BOARD)))
- KERNELNAME="uImage"
-endif
KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
CROSS_COMPILE="$(KERNEL_CROSS)" \
diff --git a/target/linux/avr32/Makefile b/target/linux/avr32/Makefile
index 62d249610e..8c85be2fd5 100644
--- a/target/linux/avr32/Makefile
+++ b/target/linux/avr32/Makefile
@@ -20,4 +20,6 @@ define Target/Description
Build firmware images for ATNGW100 board
endef
+KERNELNAME:=uImage
+
$(eval $(call BuildTarget))
diff --git a/target/linux/rdc/Makefile b/target/linux/rdc/Makefile
index be5936cfcc..9099e783e5 100644
--- a/target/linux/rdc/Makefile
+++ b/target/linux/rdc/Makefile
@@ -16,6 +16,8 @@ LINUX_VERSION:=2.6.32.25
include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=bzImage
+
DEFAULT_PACKAGES += wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
kmod-rdc321x-wdt
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 3cbed95426..fb365dd8ea 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -16,6 +16,8 @@ LINUX_VERSION:=2.6.32.25
include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=bzImage
+
$(eval $(call BuildTarget))
$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \