aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-14 11:37:29 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-14 11:37:29 +0000
commitabdd10c1d5b5f09368925d56f305c0218cc49f43 (patch)
treeee9e4a5e35e54c10d9ba47c5282d7e0286cf1551
parent8471d22b7cfe2c008c87f1cfa8bba14bcc27d9f9 (diff)
downloadmaster-187ad058-abdd10c1d5b5f09368925d56f305c0218cc49f43.tar.gz
master-187ad058-abdd10c1d5b5f09368925d56f305c0218cc49f43.tar.bz2
master-187ad058-abdd10c1d5b5f09368925d56f305c0218cc49f43.zip
mvebu: Replace the padjffs2 call by the generic definition
The mvebu image Makefile directly calls the padjffs2 utility, while there's an generic make function to do just that. Switch to it Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43968 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/mvebu/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 92571e2153..f265dc43d2 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -44,7 +44,7 @@ define Image/BuildKernel
endef
define Image/Build/squashfs
- $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
$(foreach nandboard,$(NANDBOARDS),$(call Image/Build/UbinizeImage,$(nandboard),,squashfs,$(UBI_OPTS));)
( \
dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \