aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-14 17:56:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-14 17:56:42 +0000
commitb0eb29e5e1d346f3325bf977d040da689abbbf3b (patch)
tree208d5da716247d056f0a9674cdd54a4a0b3a3297
parentc833d3eeb38edfeb29e7e2649031aa19a634beb1 (diff)
downloadmaster-187ad058-b0eb29e5e1d346f3325bf977d040da689abbbf3b.tar.gz
master-187ad058-b0eb29e5e1d346f3325bf977d040da689abbbf3b.tar.bz2
master-187ad058-b0eb29e5e1d346f3325bf977d040da689abbbf3b.zip
move several instances of DEFAULT:=y to profile preselections (easier for the image builder to pick up)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6096 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/broadcom-diag/Makefile1
-rw-r--r--package/broadcom-wl/Makefile2
-rw-r--r--package/wlcompat/Makefile1
-rw-r--r--target/linux/brcm-2.4/Makefile16
-rw-r--r--target/linux/brcm-2.6/Makefile2
5 files changed, 9 insertions, 13 deletions
diff --git a/package/broadcom-diag/Makefile b/package/broadcom-diag/Makefile
index 9ab377a4f8..edc1026c27 100644
--- a/package/broadcom-diag/Makefile
+++ b/package/broadcom-diag/Makefile
@@ -19,7 +19,6 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/diag
SECTION:=kernel
CATEGORY:=Kernel drivers
- DEFAULT:=y
DEPENDS:=@LINUX_2_4_BRCM||LINUX_2_6_BRCM
TITLE:=Driver for router LEDs and Buttons
VERSION:=$(PKG_RELEASE)+$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
diff --git a/package/broadcom-wl/Makefile b/package/broadcom-wl/Makefile
index 769cfe8eab..93fc378979 100644
--- a/package/broadcom-wl/Makefile
+++ b/package/broadcom-wl/Makefile
@@ -57,7 +57,6 @@ endef
define Package/wlc
$(call Package/broadcom-wl/Default)
TITLE:=wl driver setup utility
- DEFAULT:=y
DESCRIPTION:=\
This package contains an utility for initializing the proprietary Broadcom \\\
wl driver.
@@ -74,7 +73,6 @@ endef
define Package/nas
$(call Package/broadcom-wl/Default)
DEPENDS+=+nvram
- DEFAULT:=y
TITLE:=Proprietary Broadcom WPA/WPA2 authenticator
DESCRIPTION:=\
This package contains the proprietary WPA/WPA2 authenticator (nas) for the \\\
diff --git a/package/wlcompat/Makefile b/package/wlcompat/Makefile
index ceb5969d92..aa34e61aae 100644
--- a/package/wlcompat/Makefile
+++ b/package/wlcompat/Makefile
@@ -29,7 +29,6 @@ endef
define Package/kmod-wlcompat
$(call Package/kmod-wlcompat/Default)
- DEFAULT:=y
endef
define Package/kmod-wlcompat-debug
diff --git a/target/linux/brcm-2.4/Makefile b/target/linux/brcm-2.4/Makefile
index 4e1267df35..83741c1599 100644
--- a/target/linux/brcm-2.4/Makefile
+++ b/target/linux/brcm-2.4/Makefile
@@ -23,17 +23,17 @@ endef
KERNEL:=2.4
include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch nvram
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
define Profile/Broadcom
NAME:=Generic, Broadcom WiFi (default)
- PACKAGES:=kmod-brcm-wl
+ PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
endef
$(eval $(call Profile,Broadcom))
define Profile/BroadcomMimo
NAME:=Generic, Broadcom WiFi (MIMO)
- PACKAGES:=kmod-brcm-wl-mimo
+ PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
endef
$(eval $(call Profile,BroadcomMimo))
@@ -52,31 +52,31 @@ $(eval $(call Profile,None))
define Profile/WRT54G3G
NAME:=Linksys WRT54G3G
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
endef
$(eval $(call Profile,WRT54G3G))
define Profile/WL500G
NAME:=ASUS WL-500g
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
endef
$(eval $(call Profile,WL500G))
define Profile/WL500GD
NAME:=ASUS WL-500g Deluxe
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
endef
$(eval $(call Profile,WL500GD))
define Profile/WL500GP
NAME:=ASUS WL-500g Premium
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
endef
$(eval $(call Profile,WL500GP))
define Profile/WLHDD
NAME:=WL-HDD
- PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
endef
$(eval $(call Profile,WLHDD))
diff --git a/target/linux/brcm-2.6/Makefile b/target/linux/brcm-2.6/Makefile
index 8e69332c28..7b57fd1319 100644
--- a/target/linux/brcm-2.6/Makefile
+++ b/target/linux/brcm-2.6/Makefile
@@ -21,7 +21,7 @@ define Target/Description
endef
include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
define Profile/Atheros
NAME:=Atheros WiFi (default)