aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-12-09 19:42:00 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-12-09 19:42:00 +0000
commitc652899b773e4aa226d6f99fb3b2d6fdcc98cc51 (patch)
treec751c9512c3ca5558e1c0924068f134899c531cc
parentc462675cbbaaceedce6521510c7a2459a7345255 (diff)
downloadmaster-187ad058-c652899b773e4aa226d6f99fb3b2d6fdcc98cc51.tar.gz
master-187ad058-c652899b773e4aa226d6f99fb3b2d6fdcc98cc51.tar.bz2
master-187ad058-c652899b773e4aa226d6f99fb3b2d6fdcc98cc51.zip
ubus: fix various ACL processing problems
Bump ubus to current Git HEAD in order to: * Fix a null pointer access when user ACLs are loaded into memory * Fix wrong permission handling for uid=0, gid!=0 peers * Fix return code for permission defined cases * Fix socket error handling when the server connection dies * Make ACL file path configurable * Remove invalid usages of poll() when using a zero timeout Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47816 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/system/ubus/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/system/ubus/Makefile b/package/system/ubus/Makefile
index 3e09191b4b..b9434338fa 100644
--- a/package/system/ubus/Makefile
+++ b/package/system/ubus/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubus
-PKG_VERSION:=2015-11-19
+PKG_VERSION:=2015-12-09
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=http://git.openwrt.org/project/ubus.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=259450f414d8c9ee41896e8e6d6bc57ec00e2b63
+PKG_SOURCE_VERSION:=766d49876f8f877f4846c16864e7f73b5a3917f7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MIRROR_MD5SUM:=
CMAKE_INSTALL:=1