aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 16:51:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 16:51:25 +0000
commitdbc2b2a4e41a3eb5f48b2bd5dd7cbd5650939ac4 (patch)
tree4dde270abde34480517576d49cac15952e5c8176
parentd8595423b0a86c2fbf419f7447ebb59b3ed2420f (diff)
downloadmaster-187ad058-dbc2b2a4e41a3eb5f48b2bd5dd7cbd5650939ac4.tar.gz
master-187ad058-dbc2b2a4e41a3eb5f48b2bd5dd7cbd5650939ac4.tar.bz2
master-187ad058-dbc2b2a4e41a3eb5f48b2bd5dd7cbd5650939ac4.zip
fix mtd-utils compile on freebsd
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5020 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--tools/include/endian.h5
-rw-r--r--tools/mtd-utils/Makefile2
2 files changed, 6 insertions, 1 deletions
diff --git a/tools/include/endian.h b/tools/include/endian.h
index 4ea34cdd0f..9bfc652b90 100644
--- a/tools/include/endian.h
+++ b/tools/include/endian.h
@@ -9,6 +9,11 @@
#define bswap_16(x) NXSwapShort(x)
#define bswap_32(x) NXSwapInt(x)
#define bswap_64(x) NXSwapLongLong(x)
+#elif defined(__FreeBSD__)
+#include <sys/endian.h>
+#define bswap_16(x) bswap16(x)
+#define bswap_32(x) bswap32(x)
+#define bswap_64(x) bswap64(x)
#else
#include <machine/endian.h>
#define bswap_16(x) swap16(x)
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index 55dd88a785..f67ccf758f 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
CFLAGS := $(HOSTCFLAGS) -O2 -I../include
ifneq ($(OS),Linux)
-CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h
+CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h -include endian.h
endif
define Build/Compile