aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-02-23 21:50:10 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-02-23 21:50:10 +0000
commit6d1f6eb747c2971d81f1f2cf4b7f268491023d7e (patch)
tree8f61b47b0b29fddcbe428f40731f1d4560d98c52 /Makefile
parentaad91401670fff434f133b44e36b7462cd792ad7 (diff)
downloadmaster-187ad058-6d1f6eb747c2971d81f1f2cf4b7f268491023d7e.tar.gz
master-187ad058-6d1f6eb747c2971d81f1f2cf4b7f268491023d7e.tar.bz2
master-187ad058-6d1f6eb747c2971d81f1f2cf4b7f268491023d7e.zip
I do not believe that users will cleanup kernelsource, when switching
rootfs. force it with scripts and Makefile changes from Felix Fietkau <nbd@vd-s.ath.cx> git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@290 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 92137eac20..dfa272120b 100644
--- a/Makefile
+++ b/Makefile
@@ -166,27 +166,48 @@ $(CONFIG)/mconf:
fi
menuconfig: $(CONFIG)/mconf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/mconf $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
config: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
oldconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
randconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
allyesconfig: $(CONFIG)/conf
#@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
#sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
allnoconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
defconfig: $(CONFIG)/conf
+ -touch .config
+ -cp .config .config.test
@$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
+ -./scripts/configtest.pl
#############################################################
#