aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-05 11:24:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-05 11:24:24 +0000
commitfdb795c3e4e73747ff722d60f2368e79b5214007 (patch)
treeeae1a8c8b2fa7b37e5785012f1f98202d9410338 /include/feeds.mk
parent2f757bc989540acb986031b0b69d1274a922ef0f (diff)
downloadmaster-187ad058-fdb795c3e4e73747ff722d60f2368e79b5214007.tar.gz
master-187ad058-fdb795c3e4e73747ff722d60f2368e79b5214007.tar.bz2
master-187ad058-fdb795c3e4e73747ff722d60f2368e79b5214007.zip
build: introduce per feed repository support
This changeset implements a new menuconfig option to generate separate repositories for each enabled package feed instead of one monolithic one. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42002 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
new file mode 100644
index 0000000000..17ce64f83a
--- /dev/null
+++ b/include/feeds.mk
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+-include $(TMP_DIR)/.packagefeeds
+
+FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
+FEEDS_INSTALLED:=$(patsubst %.index,%,$(notdir $(wildcard $(TOPDIR)/feeds/*.index)))
+FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
+
+PKG_CONFIG_DEPENDS += \
+ CONFIG_PER_FEED_REPO \
+ $(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
+
+# 1: package name
+define FeedPackageDir
+$(strip $(if $(CONFIG_PER_FEED_REPO), \
+ $(abspath $(PACKAGE_DIR)/$(if $(Package/$(1)/feed),$(Package/$(1)/feed),base)), \
+ $(PACKAGE_DIR)))
+endef