aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-07-19 17:12:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-07-19 17:12:45 +0000
commitb18e0a3e11d149274c509ba07db5043723c680c1 (patch)
treeca516b3ad6cf6f85392aff86084f1ab53c61ad3a /include/image.mk
parentb3cc355d2dd4cdbfa49043addb1d82c7a1a033d1 (diff)
downloadmaster-187ad058-b18e0a3e11d149274c509ba07db5043723c680c1.tar.gz
master-187ad058-b18e0a3e11d149274c509ba07db5043723c680c1.tar.bz2
master-187ad058-b18e0a3e11d149274c509ba07db5043723c680c1.zip
image: fix initramfs image name
Preserve order of components in initramfs image filename when doing copy from $(KDIR) to $(BIN_DIR). Patchwork: http://patchwork.openwrt.org/patch/3811/ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37452 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 7d63a18232..80be17afd7 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -69,7 +69,7 @@ endef
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
define Image/BuildKernel/Initramfs
- cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-initramfs-vmlinux.elf
+ cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
$(call Image/Build/Initramfs)
endef
else