aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-16 16:10:37 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-16 16:10:37 +0000
commitf8c8d4dc570507f387d3f078d376772262fde81a (patch)
tree5ff4eb4324992722dcc68ec438f99e8694cbc583 /include/kernel.mk
parente9c14cdb264dce1705323841a27713a370ae8804 (diff)
downloadmaster-187ad058-f8c8d4dc570507f387d3f078d376772262fde81a.tar.gz
master-187ad058-f8c8d4dc570507f387d3f078d376772262fde81a.tar.bz2
master-187ad058-f8c8d4dc570507f387d3f078d376772262fde81a.zip
revert CONFIG_* symbols set m enforcement introduced in [8591], it can't work when symbols from different kernel versions are mixed in KCONFIG
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8798 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 788e3f2378..7486057052 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -115,8 +115,7 @@ $(call KernelPackage/$(1)/description)
endef
endif
- # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
- ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
+ ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)