aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 20:04:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 20:04:43 +0000
commit6665a2c1dc316cf1ebb8bc1b0ef4a44d152b0764 (patch)
tree68d7152c125e365d49961e9ab618c4b7257211d1 /include/target.mk
parent6bcd07afdd1ffcba5fe94f1291b4e4f0c764263e (diff)
downloadmaster-187ad058-6665a2c1dc316cf1ebb8bc1b0ef4a44d152b0764.tar.gz
master-187ad058-6665a2c1dc316cf1ebb8bc1b0ef4a44d152b0764.tar.bz2
master-187ad058-6665a2c1dc316cf1ebb8bc1b0ef4a44d152b0764.zip
adapt profiles for subtarget changes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8695 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/target.mk b/include/target.mk
index 42f484af9d..8f072d0cd8 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -70,13 +70,17 @@ define Profile
getvar "$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
- ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(2),$(2)_)$(1))),y)
+ ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
PROFILE=$(1)
endif
endef
-$(eval $(call shexport,Target/Description))
+-include $(PLATFORM_DIR)/profiles/*.mk
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ -include $(PLATFORM_SUBDIR)/profiles/*.mk
+endif
+$(eval $(call shexport,Target/Description))
include $(INCLUDE_DIR)/kernel-version.mk