aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-04-03 14:26:31 +0000
committerJohn Crispin <blogic@openwrt.org>2014-04-03 14:26:31 +0000
commit16ecf558d81feb2fcb38f52956f8919dd87cd1ab (patch)
tree5a1e22b9f1ebe47656cdd307d6bc77b8cf31fc18 /include
parent42d3266aa89bfbc560cdefa35da05f185d635fee (diff)
downloadmaster-187ad058-16ecf558d81feb2fcb38f52956f8919dd87cd1ab.tar.gz
master-187ad058-16ecf558d81feb2fcb38f52956f8919dd87cd1ab.tar.bz2
master-187ad058-16ecf558d81feb2fcb38f52956f8919dd87cd1ab.zip
include/make.mk: add support for ubinize-overlay.cfg
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40365 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk25
1 files changed, 15 insertions, 10 deletions
diff --git a/include/image.mk b/include/image.mk
index bc7e7dbd1b..978858a32f 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -130,6 +130,19 @@ ifneq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),)
endif
ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
+ define Image/mkfs/ubifs/generate
+ $(CP) ./ubinize$(1).cfg $(KDIR)
+ ( cd $(KDIR); \
+ $(STAGING_DIR_HOST)/bin/ubinize \
+ $(if $($(PROFILE)_UBI_OPTS), \
+ $(shell echo $($(PROFILE)_UBI_OPTS)), \
+ $(shell echo $(UBI_OPTS)) \
+ ) \
+ -o $(KDIR)/root$(1).ubi \
+ ubinize$(1).cfg \
+ )
+ endef
+
define Image/mkfs/ubifs
ifneq ($($(PROFILE)_UBIFS_OPTS)$(UBIFS_OPTS),)
@@ -150,16 +163,8 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(call Image/Build,ubifs)
ifneq ($($(PROFILE)_UBI_OPTS)$(UBI_OPTS),)
- $(CP) ./ubinize.cfg $(KDIR)
- ( cd $(KDIR); \
- $(STAGING_DIR_HOST)/bin/ubinize \
- $(if $($(PROFILE)_UBI_OPTS), \
- $(shell echo $($(PROFILE)_UBI_OPTS)), \
- $(shell echo $(UBI_OPTS)) \
- ) \
- -o $(KDIR)/root.ubi \
- ubinize.cfg \
- )
+ $(call Image/mkfs/ubifs/generate,)
+ $(if $(wildcard ./ubinize-overlay.cfg),$(call Image/mkfs/ubifs/generate,-overlay))
endif
$(call Image/Build,ubi)
endef