aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2009-03-02 17:42:29 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2009-03-02 17:42:29 +0000
commit2c21b38c09fea56d1fcb7a9e4d6c243fd543c787 (patch)
treee0b1c54d7dd9dac058ec71435894672a2dde88d9 /include
parentd65de43cd5edbede4f930265df6bfa6cef0c3fc9 (diff)
downloadmaster-187ad058-2c21b38c09fea56d1fcb7a9e4d6c243fd543c787.tar.gz
master-187ad058-2c21b38c09fea56d1fcb7a9e4d6c243fd543c787.tar.bz2
master-187ad058-2c21b38c09fea56d1fcb7a9e4d6c243fd543c787.zip
don't abort if the operation is failing
( if the board is connected via NFS files might be created by root and can't be changed at this point of time ) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14729 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 7de2d6346e..3341f10e50 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -103,9 +103,9 @@ endif
define Image/mkfs/prepare/default
- find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
- find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
- find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
+ - find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+ - find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
+ - find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
$(INSTALL_DIR) $(TARGET_DIR)/tmp
chmod 0777 $(TARGET_DIR)/tmp
endef