aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-30 13:03:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-30 13:03:58 +0000
commit3166bd1ea8bf99b9363f3a71c40a1e4679df736f (patch)
treec49a98554267f94cc8fc427d82da99286184867f /include
parenta67797adae14b46b52af6ccb3b843970b33fd615 (diff)
downloadmaster-187ad058-3166bd1ea8bf99b9363f3a71c40a1e4679df736f.tar.gz
master-187ad058-3166bd1ea8bf99b9363f3a71c40a1e4679df736f.tar.bz2
master-187ad058-3166bd1ea8bf99b9363f3a71c40a1e4679df736f.zip
image.mk: fix initramfs kernel build instructions leaking across device sections
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45156 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 0d388ec666..08b516d854 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -353,7 +353,7 @@ define Device/ExportVar
$(1) : $(2):=$$($(2))
endef
-Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL,$(call Device/ExportVar,$(1),$(var)))
+Device/Export = $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
define Device/Check
_TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)