aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:07 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-02 12:44:07 +0000
commit6d5d06b702de881cd50a2688c4848ee54ddb1b49 (patch)
treecd5cb9dccfae808cd4b19e6b7809716b6fbad5a5 /include
parent6c2dc179527dc3f1bf1fb7600f00d9a62fc38809 (diff)
downloadmaster-187ad058-6d5d06b702de881cd50a2688c4848ee54ddb1b49.tar.gz
master-187ad058-6d5d06b702de881cd50a2688c4848ee54ddb1b49.tar.bz2
master-187ad058-6d5d06b702de881cd50a2688c4848ee54ddb1b49.zip
image: ext4: allow creation of a journaling filesystem
Signed-off-by: Michael Heimpold <mhei@heimpold.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40925 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index e9cb0cc8f0..2f60ce06d9 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -190,7 +190,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
# generate an ext2 fs
$(STAGING_DIR_HOST)/bin/genext2fs -U -B $(CONFIG_TARGET_EXT4_BLOCKSIZE) -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT) $(MKFS_DEVTABLE_OPT)
# convert it to ext4
- $(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
+ $(STAGING_DIR_HOST)/bin/tune2fs $(if $(CONFIG_TARGET_EXT4_JOURNAL),-j) -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
# fix it up
$(STAGING_DIR_HOST)/bin/e2fsck -fy $(KDIR)/root.ext4
$(call Image/Build,ext4)