aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-25 14:30:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-25 14:30:53 +0000
commit8db4079bb35e4137c81db136aedbc29b7e613e74 (patch)
treeab26f190e6fb964aa14991f46ca9a66f25582ffc /include
parente11b30a9873ac1d3a3049546d856273b97ec171e (diff)
downloadmaster-187ad058-8db4079bb35e4137c81db136aedbc29b7e613e74.tar.gz
master-187ad058-8db4079bb35e4137c81db136aedbc29b7e613e74.tar.bz2
master-187ad058-8db4079bb35e4137c81db136aedbc29b7e613e74.zip
image.mk: allow image build code to run a per-filesystem prepare step
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44979 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index e0f12e0e87..8d21f24c24 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -268,6 +268,8 @@ define BuildImage/mkfs
.PHONY: mkfs-$(1)
mkfs-$(1): mkfs_prepare
$(Image/mkfs/$(1))
+ $(call Build/mkfs/default,$(1))
+ $(call Build/mkfs/$(1),$(1))
$(KDIR)/root.$(1): mkfs-$(1)
endef