aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-05 16:58:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-05 16:58:16 +0000
commitdb910597d7377551b66d888abce5fe79645dd013 (patch)
tree5bf540ed68159a9219a28d99122d713c6a2503d8 /include
parent6ca4824bc36c97fc1e75c8c681d0f1d027735cec (diff)
downloadmaster-187ad058-db910597d7377551b66d888abce5fe79645dd013.tar.gz
master-187ad058-db910597d7377551b66d888abce5fe79645dd013.tar.bz2
master-187ad058-db910597d7377551b66d888abce5fe79645dd013.zip
build: make sure modules are modposted after initramfs image is built
Otherwise the modpost steps for individual modules that are compiled manually (using make package/<name_of_module>/install) will give warning of missing symbols when that module depends other modules. This is caused by the Module.symvers file not containing any symbols anymore of external modules when the initramfs image is built without specifically giving the modules target. Signed-off-by: Tjalling Hattink <t.hattink@fugro.nl> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42773 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel-defaults.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index da06abd0a5..523cd5c483 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -150,7 +150,7 @@ endef
define Kernel/CompileImage/Default
rm -f $(TARGET_DIR)/init
- +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
+ +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME)) modules
#")
$(call Kernel/CopyImage)
endef
@@ -160,7 +160,7 @@ define Kernel/CompileImage/Initramfs
$(call Kernel/Configure/Initramfs)
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/init $(TARGET_DIR)/init
rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
- +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
+ +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME)) modules
#")
#")
$(call Kernel/CopyImage,-initramfs)