aboutsummaryrefslogtreecommitdiffstats
path: root/package/6to4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-03-15 09:49:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-03-15 09:49:33 +0000
commit864d2b9aeed2ee736de2b7c8d9dc765290e62e1e (patch)
treeeb49ba004dc787510baa7de9d48f3f9557755c55 /package/6to4/Makefile
parentfe29d066d54e2baa717c7464aad72c3343dff6ff (diff)
downloadmaster-187ad058-864d2b9aeed2ee736de2b7c8d9dc765290e62e1e.tar.gz
master-187ad058-864d2b9aeed2ee736de2b7c8d9dc765290e62e1e.tar.bz2
master-187ad058-864d2b9aeed2ee736de2b7c8d9dc765290e62e1e.zip
6to4: add netifd support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30949 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/6to4/Makefile')
-rw-r--r--package/6to4/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/package/6to4/Makefile b/package/6to4/Makefile
index 8cf66c0a28..45639646cc 100644
--- a/package/6to4/Makefile
+++ b/package/6to4/Makefile
@@ -34,11 +34,20 @@ endef
define Build/Configure
endef
-define Package/6to4/install
- $(INSTALL_DIR) $(1)/lib/network
- $(INSTALL_DATA) ./files/6to4.sh $(1)/lib/network/6to4.sh
+ifneq ($(CONFIG_PACKAGE_netifd),)
+ define Package/6to4/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/6to4.sh $(1)/lib/netifd/proto/6to4.sh
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_DATA) ./files/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
-endef
+ endef
+else
+ define Package/6to4/install
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files.old/6to4.sh $(1)/lib/network/6to4.sh
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files.old/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
+ endef
+endif
$(eval $(call BuildPackage,6to4))