aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-04 17:03:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-04 17:03:18 +0000
commit122220eb0d327f8af95a13123a546f06c3b4cd51 (patch)
tree2e33a54dd8a3cdc4d35e3bed64c55ce5ee716d72 /package/Makefile
parentc376c6b4fa116f8329d7e0a0887750f724eec329 (diff)
downloadmaster-187ad058-122220eb0d327f8af95a13123a546f06c3b4cd51.tar.gz
master-187ad058-122220eb0d327f8af95a13123a546f06c3b4cd51.tar.bz2
master-187ad058-122220eb0d327f8af95a13123a546f06c3b4cd51.zip
Add php4 package (Thanks aorlinsk and enzo for the help)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1334 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 4e8f5de966..4c743b9bfd 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -85,6 +85,7 @@ package-$(BR2_PACKAGE_OPENSWAN) += openswan
package-$(BR2_PACKAGE_OPENVPN) += openvpn
package-$(BR2_PACKAGE_OSIRIS) += osiris
package-$(BR2_PACKAGE_PCRE) += pcre
+package-$(BR2_PACKAGE_PHP4) += php4
package-$(BR2_PACKAGE_PICOCOM) += picocom
package-$(BR2_PACKAGE_PMACCT) += pmacct
package-$(BR2_PACKAGE_POPT) += popt
@@ -211,6 +212,28 @@ ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
openvpn-compile: lzo-compile
endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
+php4-compile: libgd-compile libpng-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_LDAP),)
+php4-compile: openldap-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_MYSQL),)
+php4-compile: mysql-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_OPENSSL),)
+php4-compile: openssl-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_PCRE),)
+php4-compile: pcre-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_PGSQL),)
+php4-compile: postgresql-compile
+endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_SQLITE),)
+php4-compile: sqlite2-compile
+endif
+
pmacct-compile: libpcap-compile
ifneq ($(BR2_PACKAGE_PMACCT_MYSQL),)
pmacct-compile: mysql-compile