aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
commite295e9cf7cfbd7f30c932549588867c137c9d103 (patch)
tree463c013e23557a5b9082ada45a3d7b583857450e /package/Makefile
parent767792e7a621d580a23e8ba0df1bf2c1f664f744 (diff)
downloadmaster-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.tar.gz
master-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.tar.bz2
master-187ad058-e295e9cf7cfbd7f30c932549588867c137c9d103.zip
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 99696770c1..2db33703b2 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -1,6 +1,7 @@
# Main makefile for the packages
include $(TOPDIR)/rules.mk
+package-:=tcp_wrappers
package-y:=openwrt
package-$(BR2_PACKAGE_AICCU) += aiccu
package-$(BR2_PACKAGE_ARPTABLES) += arptables
@@ -52,6 +53,7 @@ package-$(BR2_PACKAGE_ZLIB) += zlib
package-$(BR2_PACKAGE_DHCPFWD) += dhcp-forwarder
package-$(BR2_PACKAGE_LIBNET) += libnet
package-$(BR2_PACKAGE_LIBMYSQLCLIENT) += mysql
+package-$(BR2_PACKAGE_LIBPCAP) += libpcap
package-$(BR2_PACKAGE_LIBPQ) += postgresql
all: compile install
@@ -77,7 +79,7 @@ libnet-compile: libpcap-compile
mysql-compile: ncurses-compile zlib-compile
postgresql-compile: zlib-compile
-$(patsubst %,%-prepare,$(package-y) $(package-m)): linux-install
+$(patsubst %,%-prepare,$(package-y) $(package-m) $(package-)): linux-install
%-prepare:
@[ -f $(STAMP_DIR)/.$@ ] || $(MAKE) -C $(patsubst %-prepare,%,$@) prepare