aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-24 12:05:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-24 12:05:52 +0000
commitcd3c2a39aabaa6192034ace7e981b45f5b05bce9 (patch)
treeb88c0e3adba436ca1c52dd37c032600bc6516687 /package/base-files/Makefile
parenta674e08fafed09460954bfe267c52d590d3598bf (diff)
downloadmaster-187ad058-cd3c2a39aabaa6192034ace7e981b45f5b05bce9.tar.gz
master-187ad058-cd3c2a39aabaa6192034ace7e981b45f5b05bce9.tar.bz2
master-187ad058-cd3c2a39aabaa6192034ace7e981b45f5b05bce9.zip
use separate sysctl.conf files for 2.4 and 2.6 - fixes some boot message spam
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7043 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1e1610c5d7..e267b7f78b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -13,7 +13,7 @@ PKG_NAME:=base-files
PKG_RELEASE:=8
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
-PKG_FILE_DEPEND:=$(PLATFORM_DIR)
+PKG_FILE_DEPEND:=$(PLATFORM_DIR) $(GENERIC_PLATFORM_DIR)/base-files
REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
ifeq ($(REV),)
@@ -110,6 +110,9 @@ endef
define Package/base-files$(TARGET)/install
$(CP) ./files/* $(1)/
+ if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
+ $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
+ fi
if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
fi