aboutsummaryrefslogtreecommitdiffstats
path: root/package/bluez-libs
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
commiteccc8e9b8572057c6d0d5893bc95e151a9be7076 (patch)
treeb97901ef3f7cc44a098458b2f76056e24db0ef43 /package/bluez-libs
parent4b30f2c041d2983c5c8707b004589ea085ac2abb (diff)
downloadmaster-187ad058-eccc8e9b8572057c6d0d5893bc95e151a9be7076.tar.gz
master-187ad058-eccc8e9b8572057c6d0d5893bc95e151a9be7076.tar.bz2
master-187ad058-eccc8e9b8572057c6d0d5893bc95e151a9be7076.zip
Fix building when host and target systems are same arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/bluez-libs')
-rw-r--r--package/bluez-libs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/bluez-libs/Makefile b/package/bluez-libs/Makefile
index 6a65590842..17ac5a1164 100644
--- a/package/bluez-libs/Makefile
+++ b/package/bluez-libs/Makefile
@@ -27,7 +27,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
./configure \
@@ -81,6 +81,7 @@ $(STAGING_DIR)/usr/lib/libbluetooth.so: $(PKG_BUILD_DIR)/.built
install-dev: $(STAGING_DIR)/usr/lib/libbluetooth.so
uninstall-dev:
+ rm -rf $(STAGING_DIR)/usr/include/bluetooth
rm -rf $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*}
compile: install-dev