aboutsummaryrefslogtreecommitdiffstats
path: root/package/broadcom-wl/src/wlcompat/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-10 19:00:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-10 19:00:53 +0000
commitd6248e00a005987e3bcfa0d60b045f88a4669fab (patch)
treedbe4bee46c2ad4388d4b86fc720c94a461edb4ff /package/broadcom-wl/src/wlcompat/Makefile
parente4334d49327010018faa96b49d008d3a1f1095d1 (diff)
downloadmaster-187ad058-d6248e00a005987e3bcfa0d60b045f88a4669fab.tar.gz
master-187ad058-d6248e00a005987e3bcfa0d60b045f88a4669fab.tar.bz2
master-187ad058-d6248e00a005987e3bcfa0d60b045f88a4669fab.zip
move wlcompat to the broadcom-wl package
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9528 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/broadcom-wl/src/wlcompat/Makefile')
-rw-r--r--package/broadcom-wl/src/wlcompat/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/broadcom-wl/src/wlcompat/Makefile b/package/broadcom-wl/src/wlcompat/Makefile
new file mode 100644
index 0000000000..6f3224df14
--- /dev/null
+++ b/package/broadcom-wl/src/wlcompat/Makefile
@@ -0,0 +1,25 @@
+# $Id$
+#
+# Makefile for wlcompat
+#
+# Copyright (C) 2005-2007 Felix Fietkau <nbd@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+EXTRA_CFLAGS += -DBCMDRIVER=1 -DBCMDMA64=1 -I../include
+ifneq ($(DEBUG),)
+ EXTRA_CFLAGS += -DDEBUG=1
+ _D=-debug
+endif
+
+obj-m := wlcompat$(_D).o
+modules: wlcompat$(_D).o
+
+wlcompat$(_D).o: wlcompat.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS_nostdinc) -DKBUILD_BASENAME=$(subst $(comma),_,$(subst -,_,$(*F))) $(CFLAGS_$@) -c -o $@ $<
+
+-include $(TOPDIR)/Rules.make