aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
commit48db317d21b3cd54c9162e9e9c9248643f3356f0 (patch)
tree5dadc86ab8f196d7ee7d84f83407b28befc254cf /package/busybox
parentac52578132d05373a148bc7c98e16015f495fac2 (diff)
downloadmaster-187ad058-48db317d21b3cd54c9162e9e9c9248643f3356f0.tar.gz
master-187ad058-48db317d21b3cd54c9162e9e9c9248643f3356f0.tar.bz2
master-187ad058-48db317d21b3cd54c9162e9e9c9248643f3356f0.zip
From: Joseph Roback <openwrt-devel@roback.cc>
26 Makefile patches for enabling parallel builds. Tested on Linux (8-core) and Darwin (12-core), individually and from clean build_root. The first set is from trunk, the second is from feeds/packages. Signed-off-by: Joe Roback <joe@roback.cc> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22965 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 7e7e447b44..4ea9a61e4e 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -16,6 +16,8 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=7360b7138b899ee7fc885791c740c3c3
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
ifeq ($(DUMP),)
@@ -65,7 +67,7 @@ ifdef CONFIG_GCC_VERSION_4_5_0
endif
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
KBUILD_HAVE_NLS=no \