aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-08-04 09:14:20 +0000
committerMike Baker <mbm@openwrt.org>2006-08-04 09:14:20 +0000
commit834f9176191f8a245cd1bc856e37f99e94b47f6f (patch)
tree01d7795a5a4f775f07954784496c37d2091ed565 /package/busybox
parenta4a9ba8874ca977095ae4314253c5ae3420f270a (diff)
downloadmaster-187ad058-834f9176191f8a245cd1bc856e37f99e94b47f6f.tar.gz
master-187ad058-834f9176191f8a245cd1bc856e37f99e94b47f6f.tar.bz2
master-187ad058-834f9176191f8a245cd1bc856e37f99e94b47f6f.zip
fix everything I broke with the previous patches
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4436 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index afe7c59e3f..67f7ce1816 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -38,12 +38,13 @@ endef
define Build/Configure
$(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
- yes '' | $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" -C $(PKG_BUILD_DIR) oldconfig
+ yes '' | PATH="$(TARGET_PATH)" $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" \
+ -C $(PKG_BUILD_DIR) oldconfig
endef
define Package/busybox/install
- $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" PREFIX="$(1)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
+ PATH="$(TARGET_PATH)" $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" \
+ PREFIX="$(1)" EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
-rm -rf $(1)/lib64
endef