aboutsummaryrefslogtreecommitdiffstats
path: root/package/busybox
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-22 20:18:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-22 20:18:19 +0000
commitde875a123fa42cb0457b2f63c078e904d3a90f29 (patch)
tree4b72f89c8dc8d57277c39ea9f55cfaf6495ebc96 /package/busybox
parent6f136e85ce13f4c033ccc232879960b08251f10b (diff)
downloadmaster-187ad058-de875a123fa42cb0457b2f63c078e904d3a90f29.tar.gz
master-187ad058-de875a123fa42cb0457b2f63c078e904d3a90f29.tar.bz2
master-187ad058-de875a123fa42cb0457b2f63c078e904d3a90f29.zip
busybox: fix spurious rebuild issue
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14975 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index b0f0fc8f28..3f27ec66c4 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -68,9 +68,7 @@ define Build/Compile
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
all
-endef
-
-define Package/busybox/install
+ rm -rf $(PKG_INSTALL_DIR)
$(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
@@ -78,9 +76,13 @@ define Package/busybox/install
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
ARCH="$(ARCH)" \
IPKG_ARCH="$(ARCH)" \
- CONFIG_PREFIX="$(1)" \
+ CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
install
+endef
+
+define Package/busybox/install
$(INSTALL_DIR) $(1)/etc/init.d
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
for tmp in $(init-y); do \
$(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
done