aboutsummaryrefslogtreecommitdiffstats
path: root/package/e2fsprogs
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-03-06 04:00:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-03-06 04:00:22 +0000
commit980d3e646146f7e6ea70edae09f38b0cb4858511 (patch)
treecdda5d8c147798f72d59600e242166a3bdf6e169 /package/e2fsprogs
parent8aa93e0c26d1a1e8e2446759ae11b6cd315c90dd (diff)
downloadmaster-187ad058-980d3e646146f7e6ea70edae09f38b0cb4858511.tar.gz
master-187ad058-980d3e646146f7e6ea70edae09f38b0cb4858511.tar.bz2
master-187ad058-980d3e646146f7e6ea70edae09f38b0cb4858511.zip
[package] package blkid out of e2fsprogs (#4720)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14756 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/e2fsprogs')
-rw-r--r--package/e2fsprogs/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index b8bf345a91..d284a82b9b 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -101,6 +101,12 @@ $(call Package/e2fsprogs)
DEPENDS:=e2fsprogs
endef
+define Package/blkid
+$(call Package/e2fsprogs)
+ TITLE:=Command-line utility to locate/print block device attributes
+ DEPENDS:=e2fsprogs
+endef
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
@@ -186,6 +192,11 @@ define Package/badblocks/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
endef
+define Package/blkid/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/blkid $(1)/usr/sbin/
+endef
+
$(eval $(call BuildPackage,e2fsprogs))
$(eval $(call BuildPackage,libuuid))
$(eval $(call BuildPackage,uuidgen))
@@ -194,3 +205,4 @@ $(eval $(call BuildPackage,libext2fs))
$(eval $(call BuildPackage,tune2fs))
$(eval $(call BuildPackage,resize2fs))
$(eval $(call BuildPackage,badblocks))
+$(eval $(call BuildPackage,blkid))