aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-10-10 12:32:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-10-10 12:32:29 +0000
commitabe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5 (patch)
tree46b83031a0da1b4458317413c00d13c252c72afa /package/firewall/Makefile
parent41d09b7d7880b83b0e544574296b2b3673792c7f (diff)
downloadmaster-187ad058-abe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5.tar.gz
master-187ad058-abe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5.tar.bz2
master-187ad058-abe70b1494c60a3f9cbe5e4d8d967a82dd1e29a5.zip
packages: sort network related packages into package/network/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33688 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall/Makefile')
-rw-r--r--package/firewall/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
deleted file mode 100644
index 05f42a62ea..0000000000
--- a/package/firewall/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-# Copyright (C) 2008-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=firewall
-
-PKG_VERSION:=2
-PKG_RELEASE:=53
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/firewall
- SECTION:=net
- CATEGORY:=Base system
- URL:=http://openwrt.org/
- TITLE:=OpenWrt firewall
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
- DEPENDS:=+iptables +kmod-ipt-conntrack +kmod-ipt-nat
- PKGARCH:=all
-endef
-
-define Package/firewall/description
- UCI based firewall for OpenWrt
-endef
-
-define Build/Compile
- true
-endef
-
-define Package/firewall/conffiles
-/etc/config/firewall
-/etc/firewall.user
-endef
-
-define Package/firewall/install
- $(INSTALL_DIR) $(1)/lib/firewall
- $(INSTALL_DATA) ./files/lib/*.sh $(1)/lib/firewall
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) ./files/bin/fw $(1)/sbin
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
- $(INSTALL_DIR) $(1)/etc/init.d/
- $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
- $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_DATA) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
- $(INSTALL_DIR) $(1)/etc/hotplug.d/firewall
- $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/firewall/10-nat-reflection
- $(INSTALL_DIR) $(1)/etc
- $(INSTALL_DATA) ./files/firewall.user $(1)/etc
- $(INSTALL_DIR) $(1)/lib/upgrade/keep.d
- $(INSTALL_DATA) ./files/firewall.upgrade $(1)/lib/upgrade/keep.d/firewall
-endef
-
-$(eval $(call BuildPackage,firewall))