aboutsummaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-10-23 12:25:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-10-23 12:25:57 +0000
commit3dfbfb9eeb3c8d154f80111cdadc4a45d154727c (patch)
tree72f5657c80f55119548200943e428b1a363973d9 /package/firewall
parentd9ac523b000536698ba5be5a9d8b69f6e356f1d3 (diff)
downloadmaster-187ad058-3dfbfb9eeb3c8d154f80111cdadc4a45d154727c.tar.gz
master-187ad058-3dfbfb9eeb3c8d154f80111cdadc4a45d154727c.tar.bz2
master-187ad058-3dfbfb9eeb3c8d154f80111cdadc4a45d154727c.zip
[package] firewall: prevent ip6tables -t nat rules (#10265)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28535 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/fw.sh3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 8ce0295ee5..637d0ecccb 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=38
+PKG_RELEASE:=39
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/fw.sh b/package/firewall/files/lib/fw.sh
index a8a7911494..7922d222f8 100644
--- a/package/firewall/files/lib/fw.sh
+++ b/package/firewall/files/lib/fw.sh
@@ -74,7 +74,8 @@ fw__exec() { # <action> <family> <table> <chain> <target> <position> { <rules> }
fw__rc $(($? & 1))
return
fi
- fw__rc 0
+ [ "$app" != ip6tables ] || [ "$tab" != nat ]
+ fw__rc $?
}
fw__err() {