aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/vsc73x5-ucode/files
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-03-30 09:15:25 +0000
committerJohn Crispin <blogic@openwrt.org>2014-03-30 09:15:25 +0000
commitbbff25f740a1c4c9412fc0e7381eba266b261244 (patch)
tree6c2b4bcbc2e012ece0d1ae80e6adc52fb74fc72b /package/firmware/vsc73x5-ucode/files
parent5e3b47eefcbb1bcf7c89df345d6197052960ed5f (diff)
downloadmaster-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.tar.gz
master-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.tar.bz2
master-187ad058-bbff25f740a1c4c9412fc0e7381eba266b261244.zip
firmware: create a new folder for holfing firmware blobs
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware/vsc73x5-ucode/files')
-rw-r--r--package/firmware/vsc73x5-ucode/files/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/firmware/vsc73x5-ucode/files/Makefile b/package/firmware/vsc73x5-ucode/files/Makefile
new file mode 100644
index 0000000000..550f51df79
--- /dev/null
+++ b/package/firmware/vsc73x5-ucode/files/Makefile
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+CC:=gcc
+OBJCOPY:=objcopy
+
+all: g5_Plus1_2_31_unmanaged_Atheros_v3.bin \
+ g5_Plus1_2_31_unmanaged_Atheros_v4.bin \
+ g5_Plus1_2_29b_unmanaged_Atheros_v5.bin \
+ g5e_Plus1_2_29a_unmanaged_Atheros_v3.bin
+
+%.o: %.c
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+%.bin: %.o
+ $(OBJCOPY) -O binary -j .data $^ $@