aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-02-20 23:41:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-02-20 23:41:52 +0000
commit5f429a488b62aec56696c647db2caee7f41e8744 (patch)
tree57a7d5400ddf10f112255ab48f2cfc72fa4f43f4 /package/hostapd/Makefile
parent220528a6118207e751248b58b95b17682aef7660 (diff)
downloadmaster-187ad058-5f429a488b62aec56696c647db2caee7f41e8744.tar.gz
master-187ad058-5f429a488b62aec56696c647db2caee7f41e8744.tar.bz2
master-187ad058-5f429a488b62aec56696c647db2caee7f41e8744.zip
hostapd: add configurable debug message minimum priority to cut down on bloat generated by excessive debug messages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30666 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 774d08e13f..782cf73f1b 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -53,6 +53,8 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSI
include $(INCLUDE_DIR)/package.mk
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(CONFIG_WPA_MSG_MIN_PRIORITY)
+
ifneq ($(CONFIG_DRIVER_11N_SUPPORT),)
HOSTAPD_IEEE80211N:=y
endif
@@ -218,7 +220,8 @@ TARGET_CPPFLAGS := \
$(TARGET_CPPFLAGS) \
-I$(STAGING_DIR)/usr/include/madwifi \
-DCONFIG_LIBNL20 \
- -D_GNU_SOURCE
+ -D_GNU_SOURCE \
+ $(if $(CONFIG_WPA_MSG_MIN_PRIORITY),-DCONFIG_MSG_MIN_PRIORITY=$(CONFIG_WPA_MSG_MIN_PRIORITY))
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections