aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:17 +0000
commitb94a8c0025bb2d5983ba2ad1d61137f271120e80 (patch)
tree97561d65f3a6588d8d3d784ea73e7067bc68d509 /package/hostapd/Makefile
parentfcaea9057411b11859bea798ba38f9d3d1365b94 (diff)
downloadmaster-187ad058-b94a8c0025bb2d5983ba2ad1d61137f271120e80.tar.gz
master-187ad058-b94a8c0025bb2d5983ba2ad1d61137f271120e80.tar.bz2
master-187ad058-b94a8c0025bb2d5983ba2ad1d61137f271120e80.zip
hostapd: add preliminary wps script support (push-button only, does not handle multi-bss yet)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22100 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 4189922561..dcbe9e53a6 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -294,8 +294,9 @@ Package/hostapd-mini/install = $(Package/hostapd/install)
ifneq ($(LOCAL_TYPE),supplicant)
define Package/hostapd-utils/install
- $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
+ $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
endef
endif